TestFlight #8: Reminders

TestFlight #8! Natural Language Reminders

:spiral_calendar: Natural language reminders!
:lady_beetle: Fixes for some gesture conflicts
:bug: Fix for deleted shared lists
:white_check_mark: New Calendar collectible app icon

New Clear Reminder Entry

How it works:

  1. Write in a time or date, and Clear will recognize and underline it
  2. You can tap the underlined phrase to disable its scheduling if you’d like
  3. Hit done and Clear will push you at the scheduled time + display when at the top right of your item for easy scanning

Curious what you all think of it! There are things Apple’s NLP muddles up, we’re eyeing another library that seems more robust to swap out at some point. But hopefully this is useful enough to ship in the initial release.

COLLECTIBLES:
Calendar app icon

email-calendar icon

Previously:
TestFlight #7: Personalizable Gestures
TestFlight #6: List Sharing
TestFlight #5: Legacy Theme Support + Content DropTestFlight #4: Individual list personalization, 6 new collectible icons and more
TestFlight #3: Collectible App Icons, Swipe Left to Archive List and some more
TestFlight #2: Collectible Fonts & Loot Drops, NLP Reminders disabled for launch
TestFlight #1: Experimental back gesture

5 Likes

Looks good. I’m not much of a reminders user but to me it looks the same as before.

There is a new visual glitch when opening the app anew. Seems like it wants to launch the Clear menu, then shutters and decides to open the Lists menu instead. I can post a video if needed, but I’m assuming this is common?

I see this too, shouldn’t be too bad to fix but very annoying.

1 Like

Is this a bug? I remember when you add the date and time, it dissapears from the actual reminder line and turns itself into that little time/date at the upper right corner.


Huh, that is definitely a bug yes, it disappears in the main item area when I hit done / turned into tag as expected.

What is the exact string you are entering, or can I see what it is underlining when you tap to edit it again? (And what language?)

I set it up like this, with space between date/time or with comma/space between date/time and the result is the same. I set date/time always in English since iOS still doesn’t support Serbian throughout the system like an entire phone language but some of my notes are in Serbian (not sure if it makes any difference).

Before hitting done:


After hitting done:

Ok very strange, I am not reproducing it here entering the same text. (And it sounds like you have your iOS language set to English?)

Apple’s NLP API does support ‘many languages’ but I would have to imagine it’s triggered by your system wide language setting vs. context per line of text or something if your notes are in Serbian.

Hopefully there are some others experiencing this issue and can help us figure out some pattern and reproduce.

Yup, my phone language is English through and through. If it’s worth mentioning, I’m using the 11 pro and it’s on the latest iOS update with that revised Rapid Security Response.

Who knows, maybe the language mixing causes this bug, but I tested it in some other lists where I write everything in Eng and the bug persists. :man_shrugging:t2:

Might this have something to do with the region (Settings > General > Language & Region > Region) and date format ( … > Language & Region > Date Format)? Those can be set independently of language.

2 Likes

We have a small problem.

I have a todo list set up with headers for days of the week, for example:
Monday:

The reminder is turning that into, well, a reminder. See attached

Can we fix it so that headers, at least, are not susceptible?

1 Like

I’ve found that tapping on the underlined word make the underline dim, and it won’t create a reminder anymore.

2 Likes

That works! Thank you. You have to do it every time you select the item, but at least there is a workaround

Yeah you can tap the underline to disable it. But I do think it could also makes sense to not enable it if an NLP detected line is the entirety of an item as polish. Will see on that.

Also @Dragon can you see if @cmdrspock’s suggestion might be relevant to your case?

2 Likes

Just saw their reply and I’ll give it a try. But why this wasn’t an issue before? When time/date reminders were active before being removed, I haven’t had this issue.

Thanks for the suggestion, I’ll give it a try :slight_smile:

That’s a good question. I think the changes we made were:

• Strip any added logic we layered on top of Apple NLP, mostly timer and recurring support (that weren’t anywhere close to shipping)
• After hitting done it now replaces the string with the absolute timestamp, this is to prevent cases where you relative phrases like ‘tomorrow at 3pm’ get reinterpreted whenever you edit an item in the future.

Among those changes, maybe it’s that absolute timestamp swap that’s involved? But I don’t have a real theory there yet.

1 Like

Ok, solved! Thanks a lot @cmdrspock it is related to date format only. I didn’t mess with language and region. So, date format with dots between numbers 19.7.23. makes reminders in Clear go bananas but when I switch to date format with fwd slashes 19/7/23 it works like a charm:


Is it the date format Day-Month-Year or is it the dots instead of slashes that creates the bug?

edit: It’s not the format, because it works DD/MM/YY with slashes, but not dots.

I love how wonderfully intuitive the Natural Language Reminders are! This is a really exciting feature… and I didn’t even use reminders that much in the legacy app.

1 Like