AirPods are switched from Mac to iPhone when using Clear in Silent Mode

I have Clear set to Silent Mode. However, when my AirPods are connected to my Mac, if I open Clear, they still get connected to my iPhone. Silent Mode should prevent AirPods from switching to the iPhone when Clear is opened/used.

1 Like

That’s a valid point. I’m not entirely sure if we have control over this or if it is general iOS behavior, but we will try to check into this. Do the AirPods switch simply by opening Clear, or does that switch happen if you do some interaction in the app that triggers a sound effect?

It only happens when something would trigger a sound effect.

Any update on this bug? Surely just completely avoiding calling any sound routines when Silent Mode is enabled will fix it. After all, apps that don’t use sound at all don’t switch AirPods to the iPhone.

Connecting is fine, loads of third party apps do that on my iPhone, but does it actually stop it playing whatever audio is on the Mac??? Now that would be an issue.

No, connecting is not fine if I’ve disabled audio in Clear. It should not force my AirPods to switch from my Mac to my iPhone.

Actually that’s how Apple designed it. Now as long it doesn’t stop the audio playing on your Mac, that’s not an issue.

That is not how Apple designed it at all! Any other app that doesn’t use audio does NOT switch my AirPods from my Mac to my iPhone when I use it. I repeat - I’m talking about apps that do NOT play audio. I have set Clear to NOT play audio, so it should NOT switch my AirPods from my Mac to my iPhone, just like when I use any other app on my iPhone that doesn’t play audio.

Scenario 1 - Every single other app:
I’m watching a YouTube video on my Mac using my AirPods. I get an SMS on my iPhone. I open it up and read it. My AirPods remain connected to my Mac and I can still hear the YouTube video.

Scenario 2 - Clear:
I’m watching a YouTube video on my Mac using my AirPods. I decide I need to add an item to my grocery list in Clear. I open Clear. The minute I do anything that would normally cause audio to play in Clear, despite the fact that I have disabled audio, my AirPods switch to my iPhone and I can no longer hear the YouTube audio from my Mac, effectively interrupting my viewing of the video. Just because I needed to use a simple list app.

Honestly, if this bug can’t be fixed, I can’t use Clear. It’d be better if they just removed the audio if they can’t fix it.

1 Like

It’s definitely fixable. I’ve had apps that have done this before randomly and were fixed in the next update.

1 Like

Of course it can be fixed. No other apps on my iPhone behaves like this, unless you’d expect it to, such as Phone, Music, YouTube etc, where receiving a call, playing music or watching a video would be logical times to switch AirPods from another device to the iPhone, as the audio is important, or user initiated.

The Clear app is obviously still making audio API calls that trigger AirPods Automatic Switching when audio is disabled. I have apps on my iPhone that play audio, yet still don’t trigger AirPods Automatic Switching. I’d argue that due to the incidental nature of Clear’s audio, it shouldn’t trigger AirPods Automatic Switching even when audio is enabled. There’s no question that this is fixable.

More generally, any sounds effects in Clear pause currently playing music. This is definitely fixable since Due also has little sound effects when marking timers as done and it doesn’t pause the music.

I’m a developer (but not an iOS developer) so here’s a hopefully helpful thing I found:

It looks like Clear is using the “solo ambient” AVAudioSession.Category while it should be using “ambient”.

1 Like

This should really be a top priority to fix because it’s (most likely) a very simple change but currently using Clear while listening to music is insanely annoying, I have to resume it manually every single time after I do anything.

1 Like

Also happening in CarPlay. When ticking off a list item, CarPay audio stops playing the currently playing song.

2 Likes

I do have an update on this one. We’re pretty sure there are two issues.

One is if you have ‘silent mode’ setting on in Clear, this feature is not hooked up properly. It’s playing the sounds at 0 volume. I’m going to see if we can prioritize this fix for next week’s Reminders beta, and if it turns out to be that simple we should’ve prioritized it earlier.

The other is more subtle, if you don’t use that setting and enjoy the sounds in Clear, but find it getting in a state sometimes where it is interrupting music/podcasts. (I’m in this boat.) This seems like some iOS bug, in that I sometimes get in this state, and a reboot fixes it. Also I’ve noticed when my phone gets in this state Twitter app on my phone also has the same issue.

I suspect this one is some iOS issue but it’s possible we might be able to work around it. I’m just anticipating this to be a bigger can of worms.

But the silent mode issue I do think should be a quicker fix, posting about that now in our team slack.

Apologies btw on the late response here, I got kind of stretched thin the past few weeks and taking a break to catch up and recharge. I’ll update in this thread probably later today with some confirmation of the silent switch issue being either a quick fix or something more complicated.

1 Like

Any updates on this Phil?

Just checking in for updates on this issue again.

Adding to the chorus, I’m now experiencing this issue when using CarPlay. iPhone toggle is set to vibrate, but marking off items in Clear plays a sound over the car speakers and also switches the audio from the radio to the iPhone. So for example, I’m listening to the radio but have my phone plugged into CarPlay. I mark off an item, the radio goes silent, and I hear the sound effect from Clear over the car speakers. And the radio stays silent until I manually switch it back on in the car. (Doesn’t happen when playing music on the iPhone though. Music continues as normal, no sound from Clear.)

1 Like

I don’t have a real update, beyond that turning off sounds should at least prevent this issue as of a few betas ago. Looked into it briefly but didn’t find anything obvious in terms of swapping over to some other audio pipe or something like that. We have some polish time ahead of us though so maybe we will figure it out more ahead of launch.